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1. LCM 模型预处理操作 

    LCM 模型数据准备过程包括：降雨及径流预处理、入渗系数空间离散化预处理以及流

域属性预处理三个部分。LCM 模型结构如图 1-1 所示。具体模块包括：降雨时间插值模型、

径流时间插值模型、降雨空间插值操作、土地利用编码操作、土壤质地编码操作入渗系数空

间离散模型、流域属性计算操作以及等流时线调整模型。 

 

图 1-1 分布式 LCM 模型总体结构示意图 
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图 1-2 LCM 模型预处理程序示意图 

1.1 降雨、径流插值操作 

1.1.1 降雨时间插值操作 

1.1.1.1 降雨时间插值数据准备 

模型名称：EcoHAT_LCM_Pre_PrecipTempInter 

表 1-1 EcoHAT_LCM_Pre_PrecipTempInter 输入数据 

序号 输入参数 数据格式 内容 单位 

1 雨量站名称.txt 文本格式 场次降雨摘录表文本 mm 

 

表 1-2 EcoHAT_LCM_Pre_PrecipTempInter 输出数据 

序号 输出参数 数据格式 内容 单位 

1 雨量站名称_调整.txt 文本格式 等小时场次降雨数据 mm 

1.1.1.2 降雨时间插值操作 

降雨时间插值计算需要准备研究区内及周边雨量站场次降雨摘录文本。以黄河流域孤山

川流域土墩则墕雨量站 1988 年场次降雨时间插值计算为例。首先，从原始场次降雨摘录表

中选取 1988 年土墩则墕雨量站对应场次降雨记录信息（站码、年份、月日、开始时间、结

束时间和降雨量），如图 1-3 所示： 
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图 1-3 孤山川场次降雨数据摘录表 

其次，检查原始降雨摘录表中记录，去除重复项，保证摘录信息时间记录逻辑正确性。

将对应信息复制粘贴至“土墩则墕.txt”文件夹，如图 1-4 所示，确认文本最后一行与场次降雨

摘录信息最后一行相对应，使降雨时间插值程序能够正常运行。 

 

图 1-4 降雨记录文本 

再次，将研究区涉及雨量站待插值文本整理到对应文件夹下，如图 1-5 所示，为降雨时

间插值批处理做准备，批处理过程可以一次运行一个文件夹下的多个文本，减少多次重复劳

动，提高数据准备效率。 
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图 1-5 降雨记录文本文件夹管理 

全部输入数据准备好后，启动 EcoHAT 降雨时间插值计算模块，新建工程文件后调出

“降雨时间插值程序”操作界面，如图 1-6 所示，选择各雨量站场次降雨摘录表文本所在文件

夹及计算结果输出文件夹位置，即可对场次降雨数据进行时间插值处理。 

 

图 1-6 降雨数据时间插值处理程序界面 

输出数据如图 1-7 所示，为三列浮点型数组，第一列代表所在当年第 i 天，第二列为所

在当日第 j 小时，第三列为 j-0.5 到 j+0.5 时间段内的累计降雨量，单位为 mm。降雨时间插

值处理结果是降雨空间插值计算的基础数据。 
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图 1-7 降雨时间插值程序输出文本 

1.1.2 径流时间插值操作 

1.1.2.1 径流时间插值数据准备 

模型名称：EcoHAT_LCM_Pre_RunoffTempInter 

表 1-3 EcoHAT_LCM_Pre_RunoffTempInter 输入数据 

序号 输入参数 数据格式 内容 单位 

1 水文站名称 文本格式 场次径流流量数据 m3/s 

表 1-4 EcoHAT_LCM_Pre_RunoffTempInter 输出数据 

序号 输出参数 数据格式 内容 单位 

1 水文站名称_调整 文本格式 等小时径流流量数据 m3/s 

1.1.2.2 径流时间插值操作 

径流时间插值计算需要准备研究区流域出口水文站洪水要素摘录文本，以孤山川流域高

石崖水文站 1988 年径流时间插值计算为例。首先，从原始场次降雨摘录表中选取 1988 年高

石崖站对应洪水要素记录信息（年份、月日、时分和流量），如图 1-8 所示： 
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图 1-8 高石崖洪水要素摘录表 

其次，检查原始洪水要素摘录表中记录，去除重复项，保证摘录信息时间记录逻辑正确

性。将对应信息复制粘贴至“1988 孤山川.txt”文件夹，如图 1-9 所示，确认文本最后一行与

洪水要素摘录信息最后一行相对应，使径流时间插值程序能够正常运行。 

 

图 1-9 径流记录文本 
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再次，将流域水文站多年待插值洪水要素文本整理到对应文件夹下，如图 4-10 所示，

为径流时间插值批处理做准备，批处理过程可以一次运行一个文件夹下的多个文本，减少多

次重复劳动，提高数据准备效率。 

图 1-10 径流记录文本文件夹管理 

最后，全部输入数据准备好后，启动 EcoHAT 径流时间插值计算模块，新建工程文件后

调出“径流时间插值程序”操作界面，如图 1-11 所示，选择流域水文站多年洪水要素摘录文

本所在文件夹及计算结果输出文件夹位置，即可对洪水要素数据进行时间插值处理。 

 

图 1-11 径流时间插值处理程序界面 
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输出数据如图 1-12 所示，为三列浮点型数组，第一列代表所在当年第 i 天，第二列为所

在当日第 j 小时，第三列为 j-0.5 到 j+0.5 时间段内的平均流量，单位为 m3/s。径流时间插值

处理结果 LCM 模型参数率定和模拟精度评价的基础数据。 

 

图 1-12 径流时间插值程序输出文本 

1.1.3 降雨空间插值操作 

1.1.3.1 降雨空间插值数据准备 

模型名称：ARCGIS_Interpolation 

表 1-7 Interpolation 批处理输入数据 

序号 输入参数 数据格式 内容 单位 

1 插值站点.shp ARCGIS 矢量格式 雨量站空间位置及小时降雨

量 

mm 

2 批处理运行代码 excel 表格 运行 ArcGIS_Interpolation

模块 batch 模式代码 

- 

 

表 1-8 Interpolation 输出数据 

序号 输出参数 数据格式 内容 单位 

1 年月日小时.tif geotiff 格式 降雨空间插值栅格数据 mm 
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1.1.3.2 降雨空间插值操作 

降雨空间插值计算是手动操作过程，不包含 IDL 预处理模块。需要准备研究区内及周

边雨量站等小时时间间隔降雨量数据，降雨、径流数据整理表，雨量站空间坐标信息，Excel

格式批处理代码。 

首先，将降雨时间插值计算程序运行结果进行整理，保持各雨量站降雨记录、径流数据

之间时间的一致性，生成 excel 格式降雨、径流数据整理表，并选取某一时段场次降雨径流

过程，生成插值站点.shp 文件。 

第一步，从所有降雨时间插值计算结果中找出当年降雨记录开始时间最早的数据，作为

降雨、径流观测数据表的起始时间，将其它雨量站降雨时间插值结果按照对应时间顺序复制

粘贴至降雨、径流数据整理表中，生成 excel 格式的降雨、径流数据整理表，如图 1-13 所示。 

 

图 1-13 孤山川降雨、径流数据整理表 

第二步，结合雨量站空间坐标信息及对应场次降雨数据，整理获得降雨空间插值站点属

性表，如图 1-14 所示。 
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图 1-14 孤山川降雨空间插值站点属性表 

第三步，启动 ArcGis 10.3 程序，选择 File—Add Data—Add XY Data 模块，将图中表格

添加到 ArcGIS 10.3 中，并输出生成“降雨空间插值.shp”文件，其空间分布与属性信息如图

1-15 所示，同时注意添加的 XY Data 应该与计算模型的投影及椭球体保持一致，如图 1-16

所示。最后将添加的 XY Data 到处成为对应的.shp 文件。“插值站点.shp”文件是 ArcGIS 降

雨空间插值批处理的数据基础。 

 

图 1-15 插值站点空间分布及属性表 
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图 1-16 ArcGIS 空间插值批处理代码生成程序界面 

第四步，利用 Excel 生成批处理插值代码，选择雨量站插值站点.shp 文件所在路径，同

时选择插值结果输出路径，注意填写.tif 后缀，空间分辨率等信息，如图 1-17 所示，按上述

步骤进行整理，即可获得 ArcGIS 空间插值批处理代码文本。 

 

图 1-17 ArcGIS 空间插值批处理代码 

最后，将生成的批处理代码拷贝至 ArcGIS: ArcToolBox—Spatial Analyst Tools—

Interpolation—IDW（batch）对话框中，如图 1-18 所示。为了保证输出结果在范围与栅格空

间位置上与 LCM 模型其他输入数据保持一致，需要对 Environmental setting 属性进行设置，

按照 Environmental setting—Processing Extent 的路径找到：Extent 和 Snap Raster 属性，分别

选择对应的 LCM 输入数据，完成设置之后回车后即可批处理运行 IDW 插值程序，实现降
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雨数据空间插值计算，如图 1-19 所示。取消 ArcGIS 计算结果自动加载功能可以节省插值处

理耗时、提高系统运行效率，具体方法如下：在 Geoprocessing—Geoprocessing Options 下取

消“Add results of geoprocessing operations to the display”即可。 

 

图 1-18 ArcGIS 空间插值批处理界面 

 

图 1-19 ArcGIS Environmental Setting 设置界面 

1.2 入渗系数空间离散化操作 

1.2.1 土地利用编码操作 

土地利用编码操作是手动操作过程，不包含 IDL 预处理模块。需要准备研究区对应年

代土地利用.shp 文件。以孤山川为例，首先对黄河中游 1988 年土地利用解译结果.shp 文件

进行裁切，获得“孤山川 1980 年土地利用.shp”。其次，打开属性表，添加新 Field: Landuse_re，
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使用 Select by Attributes 工具选择对应的土地利用类型，在 Landuse_re 表头单击右键调用

Field Calculator 重新对属性进行赋值。赋值规则按照水体：1、城市：2、荒地：3、耕地：4、

草地：5、森林：6 的原则进行重新编码，如图 1-20 所示。 

将重新编码的矢量文件通过 ArcGIS 导出成为“.tif”格式，打开 ArcToolBox—Conversion 

Tools—To Raster—Polygon To Raster，选择正确的 Value_field，cell assignment type 选择

CELL_CENTER，同时需要对 Environmental setting 属性进行设置，按照 Environmental 

setting—Processing Extent 的路径找到：Extent 和 Snap Raster 属性，分别选择对应的 LCM 输

入数据，如图 1-21 所示。 

 

图 1-20 ArcGIS 土地利用属性表查找、重编码  
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图 1-21 ArcGIS 土地利用矢量转栅格操作  

1.2.2 土壤质地编码操作 

土壤质地编码操作是手动操作过程，不包含 IDL 预处理模块。从世界土壤数据库 HWSD

提供矢量化 1：100 万中国土壤数据中，裁剪出研究区土壤图并导出属性表，例如：另存为

土壤参数获取 .xlsx。按土壤参数获取 .xlsx 中的 SOIL 字段和 HWSD.mdb 属性表中

MU_SOURCE1 字段相同，分别查找、记录每种土壤类型的砂粒含量 T_SAND 、粘粒含量

T_CLAY 、粉粒含量 T_SILT、有机碳含量 T_OC 和碎石含量 T_GRAVEL 等特征参数。再用

图 4-17 所示 SPAW 软件分别输入每种土壤类型的砂粒含量 SAND（%）、黏粒含量 CLAY

（%）、有机质含量 Organic Matter（%）和碎石含量 Gravel（%）等参数后，查询、记录得

到每种土壤的土壤质地 Texture Class，并对土壤质地图按照黏土：1、砂质粉土：2、壤土：

3、沙土：4 的原则进行重新编码，如图 1-22 所示。 
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图 1-22 SPAW 土壤质地查询界面 

打开属性表，添加新 Field: soil_re，使用 Select by Attributes 工具选择对应的土地利用类

型，在 Landuse_re 表头单击右键调用 Field Calculator 重新对属性进行赋值。赋值规则按照

31200 : 1、29100 : 2、27100 : 3、37300 : 4、36000 : 5、20200 : 6、19300 : 7 的原则进行重新

编码，如图 1-23 所示。 

图 1-23 ArcGIS 土壤质地属性表查找、重编码  
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将重新编码的矢量文件通过 ArcGIS 导出成为“.tif”格式，打开 ArcToolBox—Conversion 

Tools—To Raster—Polygon To Raster，选择正确的 Value_field，cell assignment type 选择

CELL_CENTER，同时需要对 Environmental setting 属性进行设置，按照 Environmental 

setting—Processing Extent 的路径找到：Extent 和 Snap Raster 属性，分别选择对应的 LCM 输

入数据，如图 1-24 所示。 

图 1-24 ArcGIS 土壤质地矢量转栅格操作  

1.2.3 入渗系数空间离散操作 

1.2.3.1 入渗系数空间离散化数据准备 

模型名称：EcoHAT_LCM_Pre_Dis_r 

表 1-9 EcoHAT_LCM_Pre_Dis_r 输入数据 

序号 输入参数 数据格式 内容 单位 

1 landuse_年代 geotiff 格式 整理后土地利用栅格数据 - 

2 soiltexture_年代 geotiff 格式 整理后土壤质地栅格数据 - 

3 r_table_0 文本格式 LCM 下渗系数 r 值查找表 - 

表 1-10 EcoHAT_LCM_Pre_Dis_r 输出数据 

序号 输出参数 数据格式 内容 单位 

1 r_年代 ENVI 标准格式 入渗系数 r 空间分布 - 
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1.2.3.2 入渗系数空间离散操作 

集中整理好的输入数据，启动 EcoHAT 入渗系数 r 分布计算模块，调用“入渗系数 r 分

布计算模块”操作界面，如图 1-25 所示，按照提示选择土地利用、土壤质地数据及 LCM 入

渗系数 r 值查找表 r_table_wet.txt、r_table_dry.txt、r_table_med.txt（每次分别输入），确定计

算结果输出路径，即可获得干燥、湿润以及中等湿润入渗系数 r 值空间分布图。 

 

图 1-25 降雨时间插值处理程序界面 

1.3 流域属性计算操作 

1.3.1 GISnet 流域属性计算操作 

1.3.1.1 GISnet 流域属性计算数据准备 

模型名称：GISnet 

表 1-11 GISnet 输入数据 

序号 输入参数 数据格式 内容 单位 

1 DEM.asc ASCII 文件 流域 DEM 数据 M 

 

表 1-12 GISnet 输出数据 

序号 输出参数 数据格式 内容 单位 

1 Subbasin.asc ASCII 文件 研究区子流域划分 - 
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2 Isochrone.asc ASCII 文件 汇流时间空间分布图 H 

3 SubbasinA.txt 文本格式 子流域汇流属性 - 

1.3.1.2 GISnet 流域属性计算操作 

汇流相关数据计算需要准备研究区 DEM 数据，以孤山川流域为例。首先，裁切出流域

范围内的 DEM 数据，使用 ARCGIS 软件将流域 DEM 转换成二进制 ASCII 文件，应用叶爱

中等研发的 GISnet 数字流域信息提取系统，读入流域 DEM 数据，按照“坡度坡向—流向—

水流累积—地形指数—等流时线—河网—子流域—子流域属性”的顺序进行计算，获得研究

区二进制等流时线 isochrone.asc、子流域 subbasin.asc以及流域属性文件 SubbasinA.txt数据。

如图 1-26 所示： 

 

图 1-26 GISnet 操作界面 

1.3.2 等流时线调整程序操作 

1.3.2.1 等流时线调整数据准备 

模型名称：EcoHAT_LCM_Pre_IUH_Adjusted 

表 1-13 EcoHAT_LCM_Pre_IUH_Adjusted 输入数据 

序号 输入参数 数据格式 内容 单位 
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1 isochrone.tif ENVI 标准格式增加

后缀”.tif” 

汇流时间空间分布图 M 

2 subbasin.tif ENVI 标准格式增加

后缀”.tif” 

子流域分布图 - 

3 SubbasinA.txt 文本格式 子流域汇流属性 - 

 

表 1-14 EcoHAT_LCM_Pre_IUH_Adjusted 输出数据 

序号 输出参数 数据格式 内容 单位 

1 iuh_adjusted.tif ENVI 标准格式增加

后缀”.tif” 

调整后子流域内部等流时线

空间分布图 

H 

1.3.2.2 等流时线调整程序操作 

其次，将二进制数据 isochrone.asc、subbasin.asc 转换成 geotiff 格式影像，启动 LCM 模

型等流时线调整模块，按照提示要求选择 isochrone.tif（等流时线）、subbasin.tif（子流域空

间分布）以及 SubbasinA.txt（子流域属性图），确定计算结果输出路径，即可获得调整后以

子流域为单元的等流时线空间分布图。如图 1-27 所示。 

 

图 1-27 等流时线调整程序界面 
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2. DTVGM 模型预处理操作 

DTVGM 模型数据准备过程包括：MODIS 数据处理、计算日出日落时间、计算卫星过

境时间、计算 Kc 值、计算土壤水分参数和雪盖插值六个部分，DTVGM 模型结构如图 2-1

所示。 

 

图 2-1 DTVGM 模型总体结构示意图 

2.1MODIS 数据处理 

2.1.1 MODIS 数据拼接与投影转换 

DTVGM 模型的输入数据中一般会用到 MODIS 的地表温度和地表发射率（MOD11）、

叶面积指数/光合有效辐射吸收比率（MOD15）和积雪覆盖产品（MOD10）等，以三江平原

2014 年 MODIS LST 数据为例，介绍 MODIS 数据处理方法。 

下载 LST 数据，用 HDF 软件打开其中任一个文件，找到 LST_Day_1km 通道，位于所

有 12 个通道中的第 1 通道；再打开该文件名下拉菜单，点击 scale_factor，弹出窗口显示数

据为 0.02，表示该通道数据在实际应用时应乘以 50；点击 scale_factor_err，弹出窗口显示数

据为 0，表示该通道数据比例因子误差为 0。如图 2-2 所示。 

在电脑某一位置建立 DATA 和 DATA1 两个文件夹，文件夹内各包含的文件如图 2-3 所

示。首先，如果每一期覆盖研究区的 MODIS 数据超过一景，则需要先对数据进行拼接。将
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LST 数据拷贝至 F 盘 DATA 文件夹下，编辑 MODISmosaic 文件，根据 HDF 所查到的数据

信息，对自动拼接批处理文件进行编辑，修改文件起止时间，在倒数第 6 行修改通道信息

（如图 2-4 所示）。修改好 MODISmosaic 文件后运行文件，结果自动保存到 Result 文件夹

下。 

 

图 2-2 HDF 软件查看 LST 数据通道信息 

  

图 2-3 DATA 文件夹和 DATA1 文件夹内容 
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图 2-4 修改自动拼接批处理程序 

将生成的所有文件拷贝到 DATA1 文件夹下；然后打开 MRT 软件，设置各项参数，将

数据转成 TIF 格式，点击 Commands 栏的 Save Parameter File.按钮，将参数保存到 DATA1

文件夹下的 .prm 文件中。参数设置完毕后，运行 DATA1 文件夹下的 modis.bat 文件，结果

自动保存到 DATA1 文件夹下，参数设置如图 2-5 和 2-6 所示。 

 

图 2-5 ModisTool 参数设置（1） 
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图 2-6 ModisTool 参数设置（2） 

2.1.2 MODIS 数据插值 

利用批量修改文件名的软件，将投影转换后的数据文件名统一更改为“LST_日期”的格

式。以研究区边界为准，在 IDL 环境下运行 EcoHAT 批量裁剪工具进行数据批量裁剪，得

到 Envi 标准格式的 LST 裁剪结果文件，如图 2-7 所示。 

 

图 2-7 裁剪后的 LST 文件 

由于MODIS数据在空间上可能存在缺值现象，因此对裁剪后的数据需要进行空间插值。

启动 EcoHAT 空间插值模块，新建工程文件后调出“空间插值程序”操作界面，如图 2-8 所示。

在程序界面中输入数据前缀、插值开始时间、结束时间以及数据的临界值（LST一般为1000），
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选择研究区 ENVI 标准格式的边界文件位置、裁剪后的 LST 数据文件夹位置以及输出路径，

如图 2-8。点击确定，空间插值结果会保持到输出路径下。 

 

图 2-8 空间插值程序界面 

由于研究需要日尺度数据，因此在空间插值后的 8 天合成产品基础上对数据进行时间

插值。启动 EcoHAT 时间插值模块，新建工程文件后调出“时间插值程序”操作界面，如图 2-

9 所示。在程序界面中输入数据前缀、插值开始时间、结束时间，选择空间插值后的 LST 数

据文件夹位置以及输出路径，如图 2-9。点击确定，时间插值结果会保持到输出路径下。 
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图 2-9 时间插值程序界面 

2.2 计算日出日落时间 

2.2.1 计算日出日落时间数据准备 

模型名称：EcoHAT_DTVGM_Pre_suntime 

表 2-1 EcoHAT_DTVGM_Pre_suntime 输入数据 

序号 输入参数 数据格式 内容 单位 

1 Latitude_0 ENVI 标准格式 研究区纬度图 ° 

2 Longitude_0 ENVI 标准格式 研究区经度图 ° 

 

表 2-2 EcoHAT_DTVGM_Pre_suntime 输出数据 

序号 输出参数 数据格式 内容 单位 

1 T_rise+日期 ENVI 标准格式 日出时间 Hr 

2 T_set+日期 ENVI 标准格式 日落时间 Hr 
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2.2.2 制作经度图和纬度图 

研究区经纬度图需要在 ArcGIS 中制作，方法如下： 

首先打开研究区边界.shp 文件，记录下能够包含研究区的范围的 X、Y 坐标。记录在 txt

文件中，保存为四至点.txt。以三江平原为例，经纬度坐标图 2-10 所示（要比研究区范围大

一些）。 

 

图 2-10 研究区四至点 

在 ArcGIS 中打开四至点文件，右键选择 Display XY Data 进行设置，X 表示经度，Y 表

示纬度，设置地理坐标系统为 WGS 1984，注意不是设置投影坐标，如图 2-11。打开

ArcToolBox—3D Analyst Tool—Data Management—Create TIN，设置文件保存路径、投影坐

标以及输入属性，其中 Heigh source 选择经度，确定后生成经度 TIN（同样的方法，选择纬

度，计算纬度 TIN），如图 2-12。然后打开 ArcToolBox—3D Analyst Tool—Conversion—TIN 

to Raster，输入刚才生成的 TIN，注意设置栅格大小为 1000（目标栅格大小），重采样方法

为双线性采样（默认的最近邻采样法，会导致结果成格子状），如图 2-13。将 Raster 转为.tif

格式，根据行政边界的栅格图像分别裁剪 X、Y 的 Grid 图像，生成 ENVI 格式的研究区

Latidude_0 和 Longitude_0。 
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图 2-11 Display XY Data 设置 
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图 2-12 Create TIN 设置

 

图 2-13 TIN to Raster 设置 

2.2.3 计算日出日落时间操作 

启动 EcoHAT 日出日落时间模块，新建工程文件后调出“日出日落时间计算程序”操作界

面，如图 2-14 所示。在程序界面中输入数据开始时间、结束时间，选择上一步生成的研究

区 Latidude_0 和 Longitude_0 文件位置，设置输出路径。点击确定，输出结果为 T_rise+日

期、T_set_+日期 数据。 
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图 2-14 日出日落时间计算程序操作界面 

2.3 计算卫星过境时间 

2.3.1 计算卫星过境时间数据准备 

模型名称：EcoHAT_DTVGM_Pre_Viewtime 

表 2-3 EcoHAT_DTVGM_Pre_Viewtime 输入数据 

序号 输入参数 数据格式 内容 单位 

1 Boundary_0 ENVI 标准格式 研究区边界 - 

2 Viewtime 文本格式 卫星过境时间 Hr 

 

表 2-4 EcoHAT_DTVGM_Pre_Viewtime 输出数据 

序号 输出参数 数据格式 内容 单位 

1 Viewtime +日期 ENVI 标准格式 每日卫星过境时间 Hr 

2.3.2 计算卫星过境时间操作 

根据影像数据确定卫星的过境时间，三江平原卫星过境时间为上午 11 时，将研究区卫
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星过境时间保存在 txt 文件中，其中第一列为研究区名称，第二列为卫星过境时间，如图 2-

15 所示。启动 EcoHAT 卫星过境时间模块，新建工程文件后调出“卫星过境时间计算程序”

操作界面，如图 2-16 所示。在程序界面中输入数据开始时间、结束时间，选择研究区边界

文件位置和过境时间文本文件位置，设置输出路径。点击确定，输出结果为 ViewTime+日期 

数据。 

 

图 2-15 卫星过境时间文本 

 

图 2-16 卫星过境时间计算程序操作界面 
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2.4 计算 Kc 值 

2.4.1 计算 Kc 值数据准备 

模型名称：EcoHAT_DTVGM_Pre_Kc_function 

表 2-5 EcoHAT_DTVGM_Pre_Kc_function 输入数据 

序号 输入参数 数据格式 内容 单位 

1 Landuse_0 ENVI 标准格式 研究区土地利用 - 

2 Kc 文本格式 作物系数 - 

表 2-6 EcoHAT_DTVGM_Pre_Kc_function 输出数据 

序号 输出参数 数据格式 内容 单位 

1 Kc +日期 ENVI 标准格式 每日作物系数 - 

2.3.2 计算 Kc 值操作 

 首先通过查阅文献，对研究区各土地利用作物系数进行赋值，将赋值结果保持在 txt 文

件中，如图 2-17 所示。启动 EcoHAT Kc 赋值模块，新建工程文件后调出“Kc 计算程序”操作

界面，如图 2-18 所示。在程序界面中输入数据开始时间、结束时间、年份，选择研究区土

地利用文件位置和 Kc 文本文件位置，设置输出路径。点击确定，输出结果为 Kc+日期 数

据。 

 

图 2-17 作物系数文本文件 
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图 2-18 Kc 赋值程序操作界面 

2.5 计算土壤水分参数 

2.5.1 研究区土壤理化性质 

在 ArcGIS 中打开中国土壤数据库的 Chinasoil 图层，裁出研究区所需部分，并将图层属

性表导出另存为“土壤属性.xlsx”。根据属性表中的 soil 字段，在 HWSD 数据库中查询相应

的土壤类型信息，所对应的字段为 MU_SOURCE1。需要获取的信息有：REF_DEPTH、

T_GRAVEL and S_GRAVEL（表层和深层砾石含量）、T_SAND and S_SAND（表层和深

层沙粒含量）、T_SILT and S_SILT（表层和深层粉粒含量）、T_CLAY and S_CLAY（表层

和深层粘粒含量）、T_REF_BULK_DENSITY and S_REF_BULK_DENSITY（表层和深层

土壤容重）、T_OC and S_OC（表层和深层有机碳含量）。将所查询到的信息保存到“土

壤属性. xlsx” 中。 

2.5.2 获取土壤水分参数 

利用 SPAW 软件获取不同土壤类型表层和下层的土壤水分参数，如图 2-19 所示。根据

2.5.1 中查到的土壤属性，分别输入每种土壤类型的砂粒含量 SAND（%）、黏粒含量 CLAY

（%）、有机质含量 Organic Matter（%）和碎石含量 Gravel（%）等参数后，记录每种土壤
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的 Wilting Point（凋萎含水量）、Field Capacity（田间持水量）和 Saturation（饱和含水量），

如图 2-19 所示。注意有机质含量应为有机碳含量*1.724。 

 

图 2-19 SPAW 土壤水分查询界面 

 

图 2-20 土壤属性.xlsx 

在 ArcGIS 中打开“土壤属性.xlsx”，打开研究区土壤图层属性表，打开 joins and relats—

join，关联“土壤属性.xlsx”和土壤图层属性表，将“土壤属性.xlsx”中的字段加入土壤图层

属性表，如图 2-21 所示。打开 Conversion Tools—To raster—Feature to raster，将 WCF_T、

WCF_S、WCW_T、WCW_S、WCS_T、WCS_S 六个字段分别转成栅格格式，如图 2-22 所

示，再输出为.tif 格式，最后在 ENVI 中打开另存为 ENVI 标准格式。WCF_T/WCF_S 分别
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为表层 /深层土壤田间持水量，WCW_T/WCW_S 分别为表层 /深层土壤凋萎含水量，

WCS_T/WCS_S 分别为表层/深层土壤饱和含水量。 

 

图 2-21 土壤属性.xlsx 和图层关联 

 

图 2-22 生成含水量栅格图 
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2.6 雪盖插值 

 对裁剪后的 MOD10 产品转换成二值图并线性插值为日尺度雪盖数据。启动 EcoHAT 雪

盖插值模块，新建工程文件后调出“雪盖插值程序”操作界面，如图 2-23 所示。在程序界面

中输入数据开始时间、结束时间、年份，选择经 MODIS 数据裁剪后的雪盖数据文件夹位置，

设置输出路径。点击确定，输出结果为 Snow+日期 数据。 

 

图 2-23 雪盖插值程序操作界面 

3. SVAT 模型预处理操作 

SVAT 模型预处理对象包括：气象数据的准备、植被覆盖数据的提取和反演，以及对土

壤质地特征数据的处理。具体而言，气象数据包括：太阳辐射、陆表温度、Emis31/32 波段

值、太阳时、每日瞬时气温、地表净辐射和降水数据；植被覆盖数据主要包括叶面积指数和

植被覆盖度；土壤质地特征包括土地利用类型和土壤质地数据。接下来，根据模型数据运算

的先后顺序，分别介绍三大类数据的处理及准备。 
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3.1 太阳辐射数据预处理操作 

SVAT 模型太阳辐射计算需要准备研究区内的数字高程模型 DEM_0、经度图

Longitude_0 和纬度图 Latitude_0。以制作贵阳市 106°10’-117°30’E、26°17’-27°40’N 区间的

数据为例。首先，通过地理空间数据云平台（http://www.gscloud.cn/）或 NASA 地球观测数

据与信息系统 EOSDIS 平台（http://reverb.echo.nasa.gov/reverb/）下载 DEM 数据；其次，用

ArcGIS 完成多幅 DEM 的拼接、裁剪、投影转换和数据格式转换处理。 

然后，将研究区四角点的经度和纬度数值分类存储为文本文件，如图 3-1 所示，用 ArcGIS

的 Tools\Add XY data 工具定义 X 值、Y 值和坐标系统后生成四角点矢量文件，再用 ArcGIS

的 Create TIN From Features 功能，分别按四角点矢量文件的经度和纬度数值创建 TIN，并全

部转换成 ENVI 标准数据格式。最后，根据研究区所在时区中心经度制作 Rs_para_txt_0 参

数文件，如图 3-2 所示。 

 

图 3-1 研究区四角点的经度和纬度数值分类存储 

 

图 3-2 研究区所在时区中心经度 Rs_para_txt_0 参数文件 

3.2 地表净辐射计算数据预处理操作 

地表净辐射计算需要准备研究区的每日反照率 albedo_日期，陆地表面温度 LST_日期，

MODIS 的第 31、32 波段比辐射率 Emis31_日期、Emis32_日期，日出和日落时间 T_rise_日

期、T_set_日期、瞬时气温 Tair_instant_日期和瞬时太阳辐射 Rs_instant_日期等数据。 

首先，根据空间尺度需要，通过 EOSDIS 平台下载 MODIS 的 albedo 产品如 MCD43B3，

下载 MODIS 的 LST 和 Emis 产品如 MOD11A2。下载数据为分幅、分日期存储的.hdf 格式，



42 

 

需要用 MODIS 数据处理工具 MODIS Reprojection Tool（MRT），完成所有 MODIS 平台下载

数据的拼接、投影与数据格式转换、裁剪、空间范围缺值插补和时间序列缺值插补等操作。 

3.2.1 Albedo 数据预处理 

下面以处理贵阳市 2012 年的每日反照率数据为例，进行操作过程介绍。 

第 1 步，如图 3-3 所示，登录 EOSDIS 平台下载 MODIS 产品界面，填写时间、坐标等

相关参数，下载 MCD43B3 数据。  

 

图 3-3 EOSDIS 平台下载 MODIS 产品界面 

第 2 步，在工作盘（例如 F 盘）下新建 DATA 文件夹（图 3-4），该文件夹应包含 Result

空文件夹及 MODISmosaic.bat 批处理文件、MOSAICINPUT.TXT 和 resample.log 文件；同时

在工作盘下新建 DATA1 文件夹（图 3-5），该文件夹须包含 conus.las、conus.los、my.prm、

modis.bat、 datum.txt、resample.log、spheroid.txt、nad27sp、nad83sp 等文件。 
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图 3-4 DATA 文件夹内容 

 

     图 3-5 DATA1 文件夹内容 

第 3 步，将 2012 年度所有 MCD43B3 数据总共 46 个文件拷贝至 F 盘 DATA 文件夹下

（如图 3-6 所示），用 HDF 软件打开其中任一个文件，找到 Albedo_WAS_shortwave 通道，

数一下顺序，在该卫星数据所有 20 个通道中位于第 20 通道；再打开该文件名下拉菜单，点

击 scale_factor，弹出窗口显示数据为 0.001，表示该通道数据在实际应用时应乘以 1000；点
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击 scale_factor_err，弹出窗口显示数据为 0，表示该通道数据比例因子（即 scale_factor）误

差为 0 值。如图 3-7 所示： 

 

图 3-6 所有 MCD43B3 数据拷贝至 F 盘 DATA 文件夹下 
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图 3-7 HDF 软件查看卫星数据通道信息 

第 4 步，在 DATA 文件夹下，右击 MODISmosaic.bat 文件->编辑，根据 HDF 软件所查

到的数据信息，对自动拼接批处理文件进行编辑，修改文件起讫时间，在程序倒数第 6 行将

通道信息改为 00000000000000000001（中间须有空格），最后一个数值 1，表示该运算数据

位于第 20 通道，记得保存修改结果。如图 3-8 所示： 
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图 3-8 修改自动拼接批处理程序 

第 5 步，双击 MODISmosaic.bat 文件，运行结果自动保存到 Result 文件夹下，将生成的

所有文件拷贝到 DATA1 文件夹下；然后打开 MODIS 数据处理工具软件 MRT，将 2012 年

度MCD43B3数据转换为TIF格式文件，根据MRT安装路径，点击C：\modis\bin\ModisTool.bat，

弹出 ModisTool 界面如图 3-9 所示，分别选择数据输入路径（在刚才所生成的 Result 文件夹

中选，只需选择第 1个文件名即可），在 Selected Bands框内选择相应的卫星通道，点击 Specify 

Output File 按钮选择输出路径（在 DATA1 文件夹下选择刚才从 Result 文件夹拷贝过来的文

件），在 Output File 对话框中将文件名后缀设置为 tif 格式，点击 Edit Projection Parameters

按钮设置投影参数（参见图 3-10），点击 Commands 栏的 Save Parameter File...按钮，将参数

保存到 DATA1 文件夹下的 my.prm 文件。所有参数设置完毕后，双点 DATA1 文件夹下的

modis.bat 文件，计算结果自动保存到 DATA1 文件夹下，计算过程参见图 3-11。 
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图 3-9 ModisTool：Albedo 运算参数选择 

 

图 3-10 MRT 投影参数设置 

第 6 步，将生成的文件拷贝至专门的文件夹（例如 MCD43B3.2012.TIF），用批量修改

文件名的实用程序，将格式转换后的文件名统一更改为“albedo_日期”的格式，并清空 DATA

和 DATA1 文件夹内的所有计算过程文件（不包括原有程序文件）。 

 

图 3-11 批量修改文件名 
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图 3-12 MCD43B3 数据自动转投影并生成 tif 格式文件过程示意图 

第 7步，以研究区边界数据 boundary_ok.tif为准，在 IDL环境下运行图 3-13所示EcoHAT

批量裁剪工具进行数据批量裁剪，得到 Envi 标准格式的裁剪结果文件。 
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3-13 批量裁剪文件 

注意：1）用作裁剪文件的研究区边界应为与前述 DEM 等文件投影及坐标一致的 tif 格

式栅格文件。 

2）需要将 clip 裁剪文件下的 clip_image.pro 子程序内第 25 行的目标文件名修改，必要

时还需修改第 35 行的比例因子，如图 3-14 所示： 
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图 3-14 clip_image.pro 子程序修改 

第 8 步，将第 7 步生成的 Envi 标准格式文件先作一个备份副本后，用文件名批量修改

工具给文件名加上后缀.tif，用于下一步的空间插值和时间插值，如图 3-15 所示： 
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图 3-15 用文件名批量修改工具生成 tif 格式文件 

第 9 步，albedo 数据空间插值，在 IDL 环境下运行 EcoHAT 空间范围缺值插补工具，右

击 spatio_interpolation_albedo->打开项目->构建项目，双击 spatio_interpolation_albedo_pro 子

程序，打开如图 3-16 窗口,把第 31 行输入路径替换成当前需要插值的输入文件路径，根据

图 5-2-5 HDF 软件所查到的 scale factor 比例因子 0.001,将第 49 行所乘比例因子数值设为

0.001；考虑到 Albedo 值域在 0-1 之间，在 59 行将最大值域设为 1。（注：实际操作中，程

序行列位置可能与本文所述不完全一致。） 
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图 3-16 修改空间插值程序参数 

然后，再分别将计算拟生成图形的左右上下边界最大值设为 1.0，具体参见图 3-17 和图

3-18。 
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图 3-17 设定成图左右边界最大值 

 

       图 3-18 设定成图上下边界最大值 

最后，在程序第 192 行修改计算结果输出路径和输出文件名称，并在程序相应位置（本

例为第 200 行处）再次修改输出文件名称，如图 3-19 所示。最后点击 IDL 窗口主菜单栏“重
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置”、“编译”和“运行”按钮，执行空间插值运算。 

 

图 3-19 修改空间插值程序参数 

第 10 步，albedo 数据时间插值，在 IDL 环境下运行 EcoHAT 时间范围缺值插补工具，

右击 time_albedo->打开项目->构建项目，双击 time_Albedo_pro 子程序，打开如图 3-20 窗口,

将第 8 行和第 9 行的时间修改为时间插值起止时间，在第 13 行和 15 行红色字体部分修改

为当前需要进行时间插值的文件路径，在第 30 行红色字体部分修改为拟保存路径，最后点

击 IDL 窗口主菜单栏“重置”、“编译”和“运行”按钮，执行时间插值运算。 
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图 3-20 时间插值程序设置 

再将 Albedo 空间插值和时间插值各自所生成的文件合并到一个文件夹，得到 tif 格式的

2012 年每日反照率数据；再将“批处理去后缀名.bat”文件（如图 3-21 所示）拷贝至该文件夹，

双击运行后，得到 Envi 标准格式的每日 Albedo 数据；最后记得将文件夹中的“批处理去后

缀名.bat”删除，并将第 366 天以后的数据删除。 

 

图 3-21 批处理去除文件后缀名 

3.2.2 陆地表面温度 LST 数据预处理 

第 1 步，参照 Albedo 数据处理流程，下载 MOD11A2 数据，2012 年共 46 个文件拷贝
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至 F 盘 DATA 文件夹下，用 HDF 软件打开其中任一个文件，找到 LST_Day_1km 通道，位

于所有 12 个通道中的第 1 通道；再打开该文件名下拉菜单，点击 scale_factor，弹出窗口显

示数据为 0.02，表示该通道数据在实际应用时应乘以 50；点击 scale_factor_err，弹出窗口显

示数据为 0，表示该通道数据比例因子误差为 0，如图 3-22 所示。LST 数据预处理其余步骤

参照 Albedo 数据预处理流程。 

 

图 3-22 HDF 软件查看 MOD11A2 数据 LST_Day_1km 文件通道信息 

3.2.3 Emis31 数据预处理 

第 1 步，参照 Albedo 数据预处理流程，下载 MOD11A2 数据，2012 年共 46 个文件拷

贝至 F 盘 DATA 文件夹下，用 HDF 软件打开其中任一个文件，找到 Emis_31 通道，位于所

有 12 个通道中的第 9 通道；再打开该文件名下拉菜单，点击 scale_factor，弹出窗口显示数

据为 0.002，表示该通道数据在实际应用时应乘以 500；点击 scale_factor_err，弹出窗口显示

数据为 0，表示该通道数据比例因子误差为 0；尤其注意，双击 add offset 后弹出窗口显示数

值为 0.49，表示该通道数据在实际应用时原值乘以 500 后，还须再加上 0.49，如图 3-23 所

示。Emis31 数据预处理其余步骤参照 Albedo 数据预处理流程。 
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图 3-23 HDF 软件查看 MOD11A2 数据 Emis_31 文件通道信息 

3.2.4 Emis32 数据预处理 

第 1 步，参照 Albedo 数据预处理流程，下载 MOD11A2 数据，2012 年共 46 个文件拷

贝至 F 盘 DATA 文件夹下，用 HDF 软件打开其中任一个文件，找到 Emis_32 通道，位于所

有 12 个通道中的第 10 通道；再打开该文件名下拉菜单，点击 scale_factor，弹出窗口显示数

据为 0.002，表示该通道数据在实际应用时应乘以 500；点击 scale_factor_err，弹出窗口显示

数据为 0，表示该通道数据比例因子误差为 0；尤其注意，双击 add offset 后弹出窗口显示数

值为 0.49，表示该通道数据在实际应用时原值乘以 500 后，还须再加上 0.49,如图 3-24 所示。

Emis32 数据预处理其余步骤参照 Albedo 数据预处理流程。 
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图 3-24 HDF 软件查看 MOD11A2 数据 Emis_32 文件通道信息 

3.2.5 太阳时计算 

在 IDL4.4 环境下运行图 3-24 所示 EcoHAT 计算太阳时工具，计算得到“T_rise_日期”

和“T_set_日期”格式的每日日出、日落数据。 

注意：在 IDL4.4 环境下，“编译”和“运行”按钮位于图 3-25 上部红框显示位置,先后

点击该两按钮后，弹出 suntimeModel 对话框，选择好文件输入和保存路径后，按“确定”即

可。 
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图 3-25 日出日落时间计算 

3.2.6 每日瞬时气温数据预处理 

第 1 步，通过 http://cdc.cma.gov.cn/home.do（中国气象科学数据共享服务网）

网站下载每日平均气温近似地当作卫星传感器过境时的瞬时气温，抽取出贵阳及附近气象站

计算年份气温数据，建立专门文件夹，以 txt 格式保存，如图 3-26、3-27 所示： 

 

图 3-26 研究区及周边气象站气温数据文件夹 

http://cdc.cma.gov.cn/home.do
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图 3-27 各站气温数据 txt 文件内容 

第 2 步，将上一步生成的 txt 文件数据转换成 Excel 格式保存，并将数值分别转换成摄

氏度和开氏温度，注意：1)txt 文件中的原始温度数据要除以 10 方能得到摄氏温度数据，摄

氏度数值加上 273.15 得到开氏温度数值；2）所生成的 Excel 文件中表头的 Z1 至 Z365（闰

年为 Z366）表示全年的日数。如图 3-28 所示： 

 

图 3-28 研究区每日摄氏温度表 

第 3 步，将全年开氏温度数值表以第 181 天为界，拆分成 K1 和 K2 两张 Excel 表，并

以.xls 格式保存，如图 3-29 所示： 
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图 3-29 以.xls 格式保存每半年开氏温度数值 

第 4 步，在 Arcmap 下加载研究区矢量边界，并在主菜单栏点击 View->Data Frame 

Properties,在弹出窗口的 Display 对话框选择“Decimal Degrees”,如图 3-30 所示： 

 

图 3-30 在 Arcmap 中载入研究区边界 

第 5 步，将第 3 步做好的 Excel 数据添加进 Arcmap，如图 3-31 所示： 
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图 3-31 在 Arcmap 中添加 Excel 格式开氏温度数据 

第 6 步，使添加数据以点图层显示在地图中，如图 3-32，并在图 3-32 中进行设置： 

 

图 3-32 使添加数据以点的形式显示在地图中 
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图 3-33 对添加的温度数据进行坐标和投影设置 

注意：在如图 3-33 的参数设置中，X、Y、Z 轴的顺序及名称不可变换，采用大地坐标

系，不能设置投影，然后依次点击“OK”按钮即可。 

第 7 步，对上一步生成的点图层导出并命名保存，如图 3-34 和 3-35 所示： 
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图 3-34 导出点图层 

 

图 3-35 将导出的点图层命名保存 

第 8 步，对上一步生成的点图层进行投影转换，采用 Data Management Tools->Projections 

and Transformation->Project 命令，打开投影定义窗口，将其转换成与之前图层一致的投影，

如图 3-36 和 3-37 所示。 

 

图 3-36 投影定义参数设置 
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图 3-37 K1、K2 两个温度数据点图层均定义投影 

第 9 步，对温度插值程序进行参数设置，右击程序名，在弹出窗口中点击 Edit with IDLE,

如图 3-38 所示： 
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图 3-38 打开温度插值程序编辑功能 

然后，修改文件读入和保存路径及文件名，然后点击 Run->Run Module F5，如图 3-39

所示： 

注意：在执行 Run 操作之前须在 ArcMap 中 remove 掉 K1 和 K2 两个点图层文件。 

 

图 3-39 修改温度插值程序参数 

之后在 ArcMap 中打开任一天温度文件，显示为方形区域，如图 3-40 所示，是为研究

区四个坐标点范围。因此，还需要进行裁剪。 
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图 3-40 插值生成日气温数据文件示意 

第 10 步，在 IDL 切割程序（clip）下，对上一步生成文件按研究区边界进行批量裁剪，

执行程序前须对 clip_image.pro 子程序红框内文件名进行修改，如图 3-41 所示： 

 

图 3-41 修改图像裁剪程序参数 

    然后在 IDL 窗口中右键 clip 文件名，在弹出的菜单中依次点击“构建项目”、“运行工
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程”，如图 3-42 所示，随即弹出如图 3-43 对话框，按要求填写好文件路径后（注意：前缀一

定要与输入文件名前缀一致），最后点击“确定”按钮即可。 

 

图 3-42 打开裁剪批处理程序 

 

图 3-43 影像裁剪批处理 

第 11 步，将“批处理去后缀名.bat”文件拷贝至新文件夹 Tair_instant 下，双击该批处理

文件，去掉文件后缀.tif，之后再删掉“批处理去后缀名.bat”文件，得到标准 Envi 格式的 2012

年每日 Tair_instant 数据。 
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3.3 地表潜在蒸散发计算数据预处理操作 

地表潜在蒸散发计算需要准备研究区的每日植被盖度 Vegcover_日期，瞬时气温

Tair_instant_日期，瞬时净辐射 Rn_instant_日期，数字高程模型 DEM_0 和边界 Boundary_0

等数据。其中，准备 DEM_0 数据、Tair_instant_日期和 Rn_instant_日期在前面章节已经介

绍；在此，仅只介绍植被盖度 Vegcover_日期的准备过程，EcoHAT 系统对植被盖度数的计

算，是通过叶面积指数 LAI 求得，在此过程中只需对 LAI 数据和植被聚积指数进行预处理

操作。 

3.3.1 LAI 数据预处理 

首先，参考 3.1 节，登录 EOSDIS 平台下载 MODIS 产品界面，填写相关参数，下载

MCD15A2 和 MCD12Q1 数据，并按照其中处理 MODIS 数据产品的流程处理好“Lai_日期”

格式的每日 LAI 数据和土地覆盖数据。 

第 1 步，参照 Albedo 数据预处理流程，将下载的 2012 年 MCD15A2 数据，共 46 个文

件拷贝至 F 盘 DATA 文件夹下，用 HDF 软件打开其中任一个文件，找到 LAI_1km 通道，

位于所有 6 个通道中的第 2 通道；再打开该文件名下拉菜单，点击 scale_factor，弹出窗口显

示数据为 0.1，表示该通道数据在实际应用时应乘以 10；点击 scale_factor_err，弹出窗口显

示数据为 0，表示该通道数据比例因子误差为 0；尤其注意，双击 add offset 后弹出窗口显示

数值为 0，表示该通道数据在实际应用时原值乘以 10 后，无须再加任何数值，如图 3-44 所

示。LAI 数据预处理其余步骤参照 Albedo 数据预处理流程。 
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图 3-44 HDF 软件查看 MCD15A2 数据 LAI_1km 文件通道信息 

3.3.2 植被聚集指数 Q 值预处理 

第 1 步，参照 Albedo 计算，将下载的 2012 年 MCD12Q1.2012.hdf 数据拷贝至 F 盘 DATA

文件夹下，用 HDF 软件打开，找到 Land_Cover_Type_1 通道（根据“MODIS Land Cover Date

数据说明”，Type_1 是适用于全球的土地利用分类方案，而且也只有 Type_1 既有产品又有

质量控制数据集），位于所有 16 个通道中的第 1 通道；参照 Albedo 数据处理流程（土地覆

盖数据每年一幅，但仍按批处理过程计算），依次生成裁剪后的 2012 年土地利用覆盖数据

（单幅，命名为 Q1_2012）。裁剪引导界面如图 3-45 所示： 
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图 3-45 土地覆盖数据 Q1 裁剪引导界面 

第 2 步，参考表 3-1，在 Q1 基础上，按不同土地覆盖类型分类赋值得到聚集指数图，

并转为“Q”命名的 ENVI 标准格式。具体为：在 Envi 环境下打开 Q1，点击 Basci Tools->Band 

Math，在 Enter an expression:对话框输入聚集算式： (float(b1) eq 1)*0.6+(float(b1) eq 

2)*0.8+(float(b1) eq 3)*0.6+(float(b1) eq 4)*0.8+(float(b1) eq 5)*0.7+(float(b1) eq 

6)*0.8+(float(b1) eq 7)*0.8+(float(b1) eq 8)*0.8+(float(b1) eq 9)*0.8+(float(b1) eq 

10)*0.9+(float(b1) eq 11)*0.9+(float(b1) eq 12)*0.9+(float(b1) eq 13)*0.9+(float(b1) eq 14)*0.9，

将 Q1 原有赋值重新聚类，选择保存路径和文件名，生成新的土地覆盖类型图 Q。 

表 3-1 不同土地覆被类型的聚集指数 

类型代码 类型名  类型代码 类型名  

1 常绿针叶林 0.6 10 草地 0.9 

2 常绿阔叶林 0.8 11 永久湿地 0.9 

3 落叶针叶林 0.6 12 农田 0.9 

4 落叶阔叶林 0.8 13 城市和建设用地 0.9 

5 混合林 0.7 14 农作物和自然植被交错区 0.9 

6 郁闭灌丛 0.8 15 雪/冰 - 

7 开放灌丛 0.8 16 裸地或稀疏植被 - 

8 有林草原 0.8 17 水体 - 

 
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9 稀树草原 0.8    

3.4 降水截留计算数据预处理 

SVAT 模型降水截留计算需要集中整理好研究区的每日植被盖度 Vegcover_日期、叶面

积指数 Lai_日期、降水量 precipitation_日期和 Boundary_0 后，启动 EcoHAT 软件的能量与

水分平衡计算模块，新建工程文件后调出“植被参数\植被截留”计算过程引导界面，分别输

入模拟起止年月日，按路径选择、输入数据、选择结果保存位置后，即可运行程序进行降水

截留量计算，得到“Interception_日期”格式的每日降水截留量。由于其他数据之前已经计算

过，本部分主要介绍降水量计算，具体如下： 

第 1 步，通过 http://cdc.cma.gov.cn/home.do（中国气象科学数据共享服务网）

网站下载每日降水数据，抽取出贵阳及附近气象站计算年份降水数据，建立专门文件夹，以

txt 格式保存，如图 3-46 所示： 

 

图 3-46 建立专门文件夹以 TXT 格式保存原始降水数据 

第 2 步，分别打开每个监测站点的降水数据 txt 文件，根据“气象数据集说明文档”，降

水量为 32700 的值表示微量降水，可全部替换为 0。 

第 3 步，将上一步修改好的 txt 文件数据转换成 Excel 格式保存，操作时采用在 excel 环

境下打开 txt 文件的方式，依次点击“下一步”按钮即可，以方便对降水数据的拷贝，如图 3-

http://cdc.cma.gov.cn/home.do
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47 所示。注意：1)txt 文件中的原始降水数据要除以 10 方能得到实际数据；2）所生成的 Excel

文件中表头的 Z1 至 Z365（闰年为 Z366）表示全年的日数。如图 3-48 所示： 

 

图 3-47 在 excel 环境下打开 txt 格式降水数据文件 

 

图 3-48 研究区各气象站每日降水量表 mm 

第 4 步，将全年降水数值表以第 181 天为界，拆分成 P1 和 P2 两张 Excel 表，并以.xls

格式保存，如图 3-49 所示： 
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图 3-49 以.xls 格式保存每半年降水数值 

第 5 步，在 Arcmap 下加载研究区矢量边界，并在主菜单栏点击 View->Data Frame 

Properties,在弹出窗口的 Display 对话框选择“Decimal Degrees”,如图 3-50 所示： 

 

图 3-50 在 Arcmap 中载入研究区边界 

第 6 步，将第 4 步做好的 Excel 数据添加进 Arcmap，如图 3-51 所示： 
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图 3-51 在 Arcmap 中添加每半年降水量数据 

第 7 步，使添加数据以点图层显示在地图中，如图 3-52，并在图 3-53 中进行设置： 

 

图 3-52 使添加数据以点的形式显示在地图中 
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图 3-53 对添加的降水数据进行坐标和投影设置 

注意：在如图 3-53 的参数设置中，X、Y、Z 轴的顺序及名称不可变换，采用大地坐标

系，不能设置投影，然后依次点击“OK”按钮即可。插值效果如图 3-54、3-55 所示，将该图

层导出到相应文件夹保存： 

 

图 3-54 导出点图层 
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图 3-55 将导出的点图层命名保存 

第 8 步，对上一步生成的点图层进行投影转换，采用 Data Management Tools->Projections 

and Transformation->Project 命令，打开投影定义窗口，将其转换成与之前图层一致的投影，

操作步骤如图 3-56 和 3-57 所示。 

 

图 3-56 投影定义参数设置 
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图 3-57 P1、P2 两个降水数据点图层定义投影步骤 

第 9 步，对降水插值程序进行参数设置，右击程序名，在弹出窗口中点击 Edit with IDLE,

如图 3-58 所示： 

 

图 3-58 打开降水插值程序编辑功能 
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然后，修改文件读入和保存路径及文件名，然后点击 Run->Run Module F5，如图 3-59

所示： 

注意：在执行 Run 操作之前须在 ArcMap 中 remove 掉 P1 和 P2 两个点图层文件。 

 

图 3-59 修改降水插值程序参数 

稍后在 ArcMap 中打开任一天降水文件，显示为方形区域，是为研究区四个坐标点范围，

因此，还需要进行裁剪。 

第 10 步，在 IDL 切割程序（clip）下，对上一步生成文件按研究区边界进行批量裁剪，

执行程序前须对 clip_image.pro 子程序红框内文件名进行修改（如图 3-60），修改完后，依次

点击“重置”、“编译”按钮，并保存修改结果，关闭子程序后，右击 clip 主程序弹出下拉菜单，

点击“构建项目”->“运行工程”打开如图 3-61 所示批量裁剪引导窗口，分别在不同对话框栏

填入对应文件名和路径，最后点击确定按钮即可。 

第 11 步，将“批处理去后缀名.bat”文件拷贝至新文件夹 Precipitation 下，双击该批处理

文件，去掉文件后缀.tif，之后再删掉“批处理去后缀名.bat”文件，得到标准 Envi 格式的 2012

年每日 Precipitation 数据。 
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图 3-60 修改 IDL 裁剪批处理程序 

 

图 3-61 影像裁剪批处理引导窗口  
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3.5 土壤水分运移计算数据预处理操作 

土壤水分运移计算环节需要对进行预处理操作的数据主要有土地覆盖 Landcover 数据、

土壤初始含水量 Soil_moisture_layer1_日期数据和土壤水运移计算所需的土壤水分数据和土

壤深度属性参数数据，分别介绍如下：  

3.5.1 土地覆盖数据预处理 

由于土地覆盖数据 Landcover 主要用于对根系深度的计算，因此首先新建 RootDepth 

input 2012 文件夹，管理整理好的每日叶面积指数 Lai_日期和土地覆盖 Landcover 数据，用

作计算根系深度的输入数据。由于 LAI 数据之前已经准备好，现在主要介绍土地覆盖

Landcover 数据的预处理操作。 

第 1 步，在 Arcgis10.22 下导入土地利用矢量数据，根据《中国土壤数据库》下的“土地

利用分类（六大类）”归并土地利用类型，如图 3-62 所示： 

 

图 3-62 归并后的研究区土地利用类型图 

第 2 步，用之前做的任一结果数据（例如 LAI2012015），转换出一个 tif 格式的参照数

据：在 Envi 菜单下用命令 File->Save File As->TIFF/GeoTIFF,选择原始文件，确定保存路径
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和文件名即可。 

第 3 步，将图 3-62 归并好的土地利用矢量图转换为 1km 精度的栅格图： 

在 ArcToolbox 下用命令 Coversion Tools->To Raster->polygon to Raster，弹出如图 5-5-2

窗口，导入之前归并好的土地利用矢量图，并确定计算的值（Value field）和保存路径，然

后点击 Cellsize 右下面的文件夹按钮。在随即弹出的窗口中导入第 2 步做好的 tif 文件，选

择好文件名（后缀加.tif）和保存路径后，按“Add”、然后按“Enviornments”按钮，如图 3-64

所示。在随后弹出的 Environent Settings 窗口中点击 Processing Extent 选项，在随即编出的

Extent 对话框和 Snap Raster 对话框中导入第 2 步做好的 tif 文件（精度为 1km），最后依次

点击“OK”按钮。如图 3-65 所示： 

 

图 3-63 导入土地利用矢量图 
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图 3-64 导入参考 tif 图 

 

图 3-65 设置导入数据 tif 图的环境参数 
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第 4 步，将生成的 1km 精度栅格图转换为 Envi 标准格式：在 Arcgis 环境下，将刚才生

成的数据导出（Data->Export Data）为边界以外值为 0 的 tif 格式栅格图,参数设置如图 3-66

所示。在 Envi 主菜单栏用命令 File->Open Image File 打开刚才生成的文件，在 Envi 主菜单

栏用命令 Basic Tools->Band Math，在打开的 Band Math 对话框中把计算公式设为

b1*1.000000,然后点击“OK”按钮，在随后弹出的对话窗口中设置好保存路径和文件名，按

“OK”按钮，如图 3-67 所示。检查发现新生成的文件与之前进行计算的文件在大小上有微小

差异（如图 5-7 所示），可通过调整行列号来统一；由于之前计算的文件行列值均为 117*133，

因此可将新文件改为与之前计算文件行列值一致，具体在 Envi 下先打开新文件，然后在主

菜单栏用命令 Basic Tools->Resize Data，在随即弹出的 Resize Data Input File 窗口中选择需

要进行行列值调整的文件，点击 Spatial subset 按钮，在随后弹出的 Select Spatial Subset 对话

框中修改行列值，如图 6-8。在上一小步修改完行列值后点击“OK”按钮，弹出如图 3-70 所

示窗口，可见行列值已修改好，选择保存路径和文件名后，点击“OK”按钮，即可生成所需

要的 Envi 标准格式土地覆盖栅格图。 

 

图 3-66 将边界外 NoData 值设为 0 
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图 3-67 将生成图的值由整形转为浮点型 

 

图 3-68 生成文件与之前进行计算的文件大小对比 
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图 3-69 修改行列值 

 

图 3-70 调整行列值确定保存路径 

3.5.2 土壤初始含水量计算数据预处理 

土壤初始含水量计算环节需要进行预处理的数据主要有土壤类型空间数据 Soil_type 和

土壤属性文本文件数据 Soil_property_txt，具体操作步骤如下： 

第 1 步，从世界土壤数据库 HWSD 提供矢量化 1：100 万中国土壤数据中，裁剪出研究



87 

 

区土壤图（如图 3-71 所示）并导出属性表，例如：另存为“土壤参数获取.xlsx”。 

 

图 3-71 裁剪并导出研究区土壤图属性表 

第 2 步，按土壤参数获取.xlsx 中的 SOIL 字段和 HWSD.mdb 属性表中 MU_SOURCE1

字段相同，分别查找、记录每种土壤类型的砂粒含量 T_SAND、粘粒含量 T_CLAY、粉粒含

量 T_SILT、有机碳含量 T_OC 和碎石含量 T_GRAVEL 等特征参数，如图 3-72。 

 

图 3-72 在 HWSD 属性表中查找土壤特征参数值 

第 3 步，将上一步查找到的数值按相应字段名输入到第 1 步建立的“土壤参数获取.xlsx”

表中，并新建有机质含量字段“Organic-mat”，将有机碳含量“T_OC”的值乘以 1.724 得到
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“Organic-mat”的值，如图 3-73 所示。 

 

  图 3-73 将通过 HWSD 查到的土壤特征值输入到“土壤参数获取.xlsx”表中 

第 4 步，再用图 3-74 所示 SPAW 软件分别输入每种土壤类型的砂粒含量 SAND（%）、

粘粒含量 CLAY（%）、有机质含量 Organic Matter（%）和碎石含量 Gravel（%）等参数后，

查询每种土壤的萎蔫含水量 Wilting point(%)、田间持水量 Field capacity（%）、饱和含水量

Saturation（%）、土壤有效含水量 Available water(in/ft)、饱和导水率 Sat.Hydraulic Cond（in/hr）

和土壤质地 T_Class(Texture Class)值，并新建相应字段记录到“土壤参数获取.xlsx”表中，如

图 3-75 所示。 

第 5 步，在土壤参数获取.xlsx 中按 SOIL 字段从小到大排序后，再按土壤质地 Texture 

Class，分别给每种土壤赋予表 3-2 所示的土壤水分运移概化参数；然后新建“序号”和

“Soil_type”字段，分别按数值和序列填充，对于没有土壤属性值的数值取 0，得到每种土

壤的顺序编号及其类型代码，为方便查值，采用不同颜色表示不同类型土壤的数值。如表 3-

3 所示。 
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图 3-74 SPAW 软件查询土壤含水参量 

 

图 3-75 将查询所得土壤含水参量录入“土壤参数获取.xlsx”表中 

注意：1）水体默认为重黏土，含水参量为：SWw：32.6，SWfc:43.6，SWf：52.8，

Av_w:1.3,Sat.H:0.07,Bulk_Den:78.02，T_OM：3.19348；2）岩石和城区参量为 0。 

表 3-2 土壤水分运移参数概化表 

土壤质地 P1 P2(cm) P3 P4 Ks(cm/min) Rf(1/cm) 

重黏土 0.28 70.030 0.66 0.27 0.000006 0.005 

轻黏土 0.28 50.159 0.63 0.16 0.00006 0.005 
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粉质黏土 0.31 175.995 0.80 0.11 0.0006 0.005 

壤土 0.32 186.441 0.86 0.09 0.006 0.005 

轻砂壤 0.28 247.682 0.92 0.09 0.06 0.005 

砂土 0.35 1617.929 1.68 0.04 0.6 0.005 

注意：1）水体（92000 以上）的土壤质地默认为重黏土，参数同上表中重黏土部分； 

2）岩石（91000）和城区（90000）的参数设置为 0。 

               表 3-3 土壤序号、类型及添加参数表 

 

第 6 步，用 ArcGIS 将土壤参数获取.xlsx 的全部信息，按 SOIL 字段与研究区矢量化土

壤数据属性表中的 SOIL 字段匹配，实现属性表与数据表的 Join 链接操作，得到含有更多土

壤参数信息的矢量化土壤数据，另存为 All_土壤参数信息.shp。1）将土壤参数获取.xlsx 转

换为 arcgis 认可的.xls 格式，如“贵阳土壤参数获取 001.xls”；2）在 arcgis 中右击“贵阳土壤

矢量图”->joins and relats->join…，实现将土壤矢量图与土壤参数表“贵阳土壤参数获取

001.xls”建立关联如图 3-76～78；3）在 arcgis中右击“贵阳土壤矢量图”->Data->Export Data…，

将刚才关联后的“贵阳土壤矢量图”保存为 All_贵阳土壤参数信息.shp。 
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图 3-76 将土壤矢量图与土壤参数表建立关联-1 

 

图 3-77 将土壤矢量图与土壤参数表建立关联-2 
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图 3-78 将土壤矢量图与土壤参数表建立关联-3 

第 7 步，通过点击查看图层 properties 发现，此时关联好的土壤矢量图尚未带有投影，

还不能参与计算，应将土壤矢量图投影定义为与之前各计算环节结果图一致的

Albers_Conic_Equal_Area 投影。步骤为：首先将“贵阳土壤矢量图.shp”右键点击用 Data->Data 

Export 命令导出为一幅新的矢量图“All_贵阳土壤参数信息.shp”，再在 ArcMap 下导入一幅

带有投影的图层，如“贵阳市范围 PRJ”，然后点击命令：ArcToolbox->Data Management 

Tools->projections and Transformations->Project，具体如图 3-79、80 所示。 
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   图 3-79 土壤矢量图定义投影-1 

 

图 3-80 土壤矢量图定义投影-2 

第 8 步，将上一步生成的“All_贵阳土壤参数信息_prj.shp”图层，按 Soil_type 字段匹配，

矢量转栅格得到土壤类型 Soil_Type_0 数据。用命令 ArcToolbos->Converdion Tools->To 
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Raster->Polylion to Raster,转换过程如图 3-81、82、83 所示。 

注意：1）转换后的数据应保存为.tif 格式； 

2）转换后栅格数据的像元大小设置为与之前计算结果栅格图一致的 1000米*1000米，

可以直接在图 3-81 中 Cellsize(optional)对话框里填入数值 1000，推荐在 Cellsize(optional)对

话框里导入之前做好的栅格数据（例如：Lai_2012015.tif）,然后点击下方的“Environments…”

按钮，有随后弹出的 Environments settings 窗口中的 Processing Extent 菜单下的 Extent 和 Snap 

Raster 对话框中均导入之前做好的栅格数据（例如：Lai_2012015.tif），最后依次点击“OK”按

钮，生成栅格图，这样做的好处是即将生成的栅格数据格式完全与之前做好的数据保持一致。 

3）如果按上述步骤未能转换成功，有可能是 ArcMap 默认初始打开的其他图层与“All_

贵阳土壤参数信息_prj.shp”图层的投影不一致，此时重新启动 ArcMap，仅载入“All_贵阳土

壤参数信息_prj.shp”图层进行投影转换操作即可。 

 

      图 3-81 “All_贵阳土壤参数信息_prj.shp”图转栅格-1 



95 

 

 

         图 3-82 “All_贵阳土壤参数信息_prj.shp”图转栅格-2 
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图 3-83 “All_贵阳土壤参数信息_prj.shp”图转栅格-3 

第 9 步，将转换后的栅格图层导出为 Envi 格式，在 ArcMap 下右键单击栅格图层，用

命令 Data->Export Data,具体过程如图 3-84 所示（注：NoData 值设为 0）。 
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        图 3-84 将 Soil_Type_0.tif 导出为 Envi 格式 

第 10 步，在 Envi 环境下将刚才生成的 Envi 格式图打开，转换为 Envi 标准格式文件，

具体在 Envi 主菜单用命令 File->Save File As->ENVI Standard，打开 New File Builder 窗口，

点击“Import File…”按钮导入上一步生成的 Envi 格式图层，再点击“Choose”按钮，选择保

存路径和文件名，最后点出“OK”按钮即可，如图 3-85。 

 

图 3-85 将栅格图转换为 Envi 标准格式 

第 11 步，为使生成的 Envi 文件能与之前计算结果格式一致，还需要将其值由当前的整

形改为浮点型，具体操作如下：在 Envi 主菜单栏用命令 File->Open Image File 打开刚才生

成的文件，在 Envi 主菜单栏用命令 Basic Tools->Band Math，在打开的 Band Math 对话框中

把计算公式设为 b1*1.000000,然后点击“OK”按钮，在随后弹出的对话窗口中设置好保存路

径和文件名，按“OK”按钮，如图 3-86 所示。 
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             图 3-86 将生成的 Envi 标准格式文件由整形改为浮点型 

第 12 步，上一步在修改整形文件后形成的 Envi 文件其波段名变成了（b1*1.000000），

为规范文件名，有必要修改波段名，用鼠标单击选中波段名，点击 Available Band 小窗口菜

单 File->Available File List…,在弹出的窗口中选择 Options->Edit Header…,在弹出窗口中选择

Edit Attributes->Band Names…,在随后打开的 Edit Band Name values 窗口的 Edit Selected Item

对话框中。将波段名改为 b1（图 3-87）。 
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图 3-87 规范修改波段名称 

第 13 步，将“贵阳土壤参数获取 001.xls”另存为“贵阳土壤参数获取（临时）.xls”，

用来提取表中信息。在表中选取与图 3-83 中属性表里 value 值一致的 Soil_type 数值，按顺

序排列并选中序号、Soil_type、SWfc（田间持水量）、SWw（萎蔫含水量）和 SWf（饱和含

水量）的所有列数据，复制、另存为如图 3-88 所示 Soil_Moisture_txt_0.txt 文件，作为土壤

初始含水量数据准备的输入数据。在属性表中按顺序排列和选中序号、Soil_type、P1、P2(cm)、

P3、P4、Ks(cm/min)、Rf(1/cm)、SWfc、SWw 和 SWf 的所有列数据，复制、另存为如图 3-

89 所示 Soil_property_txt_0.txt 文件，作为土壤水运移计算的输入数据。 
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              图 3-88 Soil_Moisture_txt_0.txt 参数文件 

 

图 3-89 Soil_property_txt_0.txt 参数文件 

（注意：以上两表中，“序号”两字之间不能有空格） 

第 14 步，集中整理好 Soil_Moisture_txt_0.txt 和 Soil_type_0 ，归总到新建的

Soil_moisture_layer__input 文件夹，如图 3-90 所示。 
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           图 3-90 土壤初始含水量计算输入数据文件夹 

3.5.3 土壤水运移计算数据预处理 

第 1 步，参考 2.1 登录 EOSDIS 平台下载 MODIS 产品界面，填写相关参数，按年度下

载 AE-Land3 数据，整理成相应年份数据文件夹，如 。 

第 2 步，将 2012 年度所有 AE-Land3 数据总共 366 个文件拷贝至 F 盘 DATA 文件夹下

（如图 3-91 所示），用 HDF 软件打开其中任一个文件，找到升轨土壤湿度数据

A_Soil_Moisture，数一下顺序，在该卫星产品所有 17 个通道中位于第 14 通道；如图 3-92

所示。 

第 3 步，在 DATA 文件夹下，右击 MODISmosaic.bat 文件->编辑，根据 HDF 所查到的

数据信息，对自动拼接批处理文件进行编辑，修改文件起讫时间，在程序倒数第 6 行将通道

信息改为 00000000000001000（中间须有空格），第 14 个数值 1，表示该运算数据位于第 14

通道；在程序倒数第 2 行，将“set/a DAY=%DAY%+8”改为“set/a DAY=%DAY%+1”，表示

逐日数据，记得保存修改结果。如图 3-93 所示： 
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图 3-91 将 2012 年度所有 AE_L3 数据拷贝至 F 盘 DATA 文件夹下 

 

图 3-92 HDF 软件查看卫星数据通道信息 
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图 3-93 修改自动拼接批处理程序 

第 4 步，双击 MODISmosaic.bat 文件，运行结果自动保存到 Result 文件夹下，将生成的

所有文件拷贝到 DATA1 文件夹下；然后打开 MRT 软件，将 2012 年度 AE_L3 数据转换为

TIF 格式文件，根据 MRT 安装路径，点击 C：\modis\bin\ModisTool.bat，弹出 ModisTool 界

面，分别选择数据输入路径（只需选择第 1 个文件名即可），在 Selected Bands 框内选择相

应的卫星通道，点击 Specify Output File 按钮选择输出路径（设定为 DATA1 下），在 Output 

File 对话框中将文件名后缀设置为 tif 格式，点击 Edit Projection Parameters 按钮设置投影参

数，点击 Commands 栏的 Save Parameter File...按钮，将参数保存到 DATA1 文件夹下的 my.prm

文件。所有参数设置完毕后，双点 DATA1 文件夹下的 modis.bat 文件，计算结果自动保存到

DATA1 文件夹下，具体处理过程参考 3.2.1 节 Albedo 数据预处理流程，最终得到“Soil_日

期”格式的微波同步观测土壤水分数据。 

第 5 步，制作好图 3-94 所示，包括序号、模拟土体深度 Depth(cm) 、模拟土层深度步

长 Depth_interval(cm) 、 模 拟 时 间 步 长 Time_interval(minute) 、 模 拟 降 雨 历 时

Precipitation_time(minute)的 Model_init_txt_0.txt 文件，作为土壤水运移计算的输入参数。 

 

图 3-94 Model_init_txt_0.txt 参数文件。 
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4.MUSLE 模型预处理操作说明 

4.1 MUSLE 方程 

MUSLE(Modified Universal Soil Loss Equation)是 Williams(1995)提出的 USLE (Modified 

Universal Soil Loss Equation)( Wischmeier 和 Smith,1965,1978)的修正形式，已被美国农业部

开发的 SWAT(Soil and Water Assessment Tool)模型选用，可用于估算流域、子流域、网格单

元的产沙量。MUSLE(Williams,1995)的表达式为： 

 

公式中，Sed 是产沙量(t)；Rs 为地表径流量(mm/ ha)；qpeak 为洪峰径流量(m3/s)；Apixel 为网

格面积(ha)；K 是土壤可蚀性因子(0.013 t·m2·h/(m3·t·cm))；C 是覆盖与管理因子；P 是保持

措施因子；LS 是地形因子；CFRG 是粗碎屑因子。由于产沙量可认为是上述因子的乘积，

若一个因子趋于 0，则产沙量也趋于 0 (Neitsch et al.2009)。 

4.2 MUSLE 模型需准备数据 

表 4-1 MUSLE 模型数据名称及属性 

序

号 

函数名 功能 输入数据名称及属性 

1 

EcoHAT_LCM_Rs_Pro

cedure 

地表径流函数 

运用 LCM 模型计算每日

地表径流 Rs。计算获取

的地表径流 Rs 也可为计

算洪峰径流因子 qpeak 提

供基础。 

NDVI_0：二维栅格格式,浮点型,归一化植被指数(1年1

幅影像数据,运用年内生长期遥感数据获取),无量纲。 

VegCover_0：二维栅格格式,整型,植被盖度(1年1幅影像

数据),无量纲。 

KP：二维栅格格式,浮点型,每日降雨量,单位：mm。 

RR1_0：二维栅格格式,浮点型,LCM模型中的入渗系数

r,无量纲。 

2 

EcoHAT_Time_Overla

nd_Procedure 

坡面栅格汇流时间函

计算坡面栅格汇流时间，

为计算洪峰径流因子

qpeak 提供基础。 

Slope_0：二维栅格格式,浮点形,坡度图,由 DEM生成,单

位：度。 

Flowdir_0 ：二维栅格格式,整型，流向图,DEM生成,无

0.5611.8 ( )peak pixel USLE USLE USLE USLESed Rs q A K C P LS CFRG        
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数 量纲。 

Resolution_txt：文本格式,坡度图的分辨率,单位：m。 

Landuse_0：二维栅格格式,整型，土地利用图,无量纲。 

3 

EcoHAT_K_Factor_Pro

cedure 

土壤可蚀性函数 

计算土壤可蚀性因子

K_0。 

Clay_U_0：二维栅格格式,整形,土壤粘粒含量,无量纲。 

OC_U_0：二维栅格格式,浮点型,土壤有机碳含量,无量

纲 

Sand_U_0：二维栅格格式,整形,土壤砂粒含量,取值0-

100,无量纲。 

Silt_U_0：二维栅格格式,整形,土壤粉粒含量,无量纲。 

4 

EcoHAT_C_Factor_Pro

cedure 

覆盖-管理因子函数 

计 算 覆 盖 - 管 理 因 子

C_0。 

VegCover_0：二维栅格格式,整型,植被盖度(1年1幅影像

数据),无量纲 

5 

EcoHAT_P_Factor_Pro

cedure 

水土保持措施因子函

数 

计算水土保持措施因子

P_0。 

Landuse_0：二维栅格格式,整型，土地利用图,无量纲。 

6 

EcoHAT_LS_Factor_Pr

ocedure 

地形因子函数 

计算坡度 S 和坡长 L 因

子的乘积 LS_0。 

Slope_0：二维栅格格式,浮点形,坡度图,由 DEM生成,单

位：度。 

Flowdir_0 ：二维栅格格式,整型，流向图,DEM生成,无

量纲。 

Resolution_txt：文本格式,坡度图的分辨率,单位：m。 

7 

EcoHAT_Sed_Overlan

d_Procedure 

坡面侵蚀产沙函数 

计算坡面侵蚀产沙。 

Rs：二维栅格格式,浮点形,每日地表径流，运用程序

EcoHAT_LCM_Rs_Procedure 获取。 

Tov_0 ：二维栅格格式,浮点型,栅格汇流时间(1 年 1 幅

影 像 数 据 ), 运 用 程 序

EcoHAT_Time_Overland_Procedure 获取。 

K_0：二维栅格格式,浮点型,土壤可蚀性因子,运用程序

EcoHAT_K_Factor_Procedure 获取。 

Rock_U_0：二维栅格格式,浮点型,土壤砾石含量,用以
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计算粗糙度因子,无量纲。 

C_0 ：二维栅格格式,浮点型, 覆盖-管理因子,运用程序

EcoHAT_C_Factor_Procedure获取。 

P_0：二维栅格格式,浮点型, 水土保持措施因子,运用程

序EcoHAT_P_Factor_Procedure获取。 

LS_0 ：二维栅格格式,浮点型,地形因子(坡长因子 L 和

坡 度 因 子 S 的 乘 积 ) , 运 用 程 序

EcoHAT_LS_Factor_Procedure 

获取。 

Resolution_txt：文本格式,坡度图的分辨率,单位：m。 

4.3 MUSLE 模型数据准备方法及步骤 

根据表 5-1，需准备的原始数据共有 3 类 13 种： 

第 1 类：随时间变化的影像数据 1 种，即 KP。 

第 2 类：不随时间变化的影像数据 11 种，即 NDVI_0、VegCover_0、RR1_0、Slope_0、

Flowdir_0、Landuse_0、Clay_U_0、OC_U_0、Sand_U_0、Silt_U_0、Rock_U_0。 

第 3 类：文本数据 1 种，即 Resolution_txt。 

需特别注意的是，所有准备的原始影像数据，无论是随时间变化的，还是不随时间变化

的，都必须储存为 ENVI 标准格式，且保证他们的坐标、投影、行列号等信息完全相同。 

4.3.1 随时间变化的影像数据 

随时间变化的影像数据只有 1 种，即 KP(每日降雨量)。其获取方式为： 

第一步，获取研究区气象站点日降雨数据并整理为 ArcGIS 空间插值识别的格式。 

第二步，运用 ArcGIS 中的空间插值模块，插值生成每日降雨量面数据 KP。 

4.3.2 不随时间变化的影像数据 

(1) NDVI_0 (归一化植被指数) 

第一步，定制并下载作物生长季的MODIS数据。网址为

http://reverb.echo.nasa.gov/reverb/。数据集为MODIS/Terra Vegetation Indices 16-Day L3 

http://reverb.echo.nasa.gov/reverb/。数据集为MODIS/Terra%20Vegetation%20Indices%2016-Day%20L3
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Global 250m SIN Grid V005。 

第二步，NDVI 数据预处理。用 ModisTool 软件对下载的 MOD13_250mNDVI 产品进行

拼接、投影转换和格式转换等一系列处理。 

    第三步，NDVI 值域转化。拼接转投影之后影像的数据范围为-2000-10000，其中-3000 是

无效值。运用 ENVI 软件，通过 ENVI- Basic Tools-Preprocessing Data-Specific Utilities - 

View HDF Attribute 查看 HDF 数据集的属性，发现比例系数 Scale_factor 为 10000。对于陆

地表面主要覆盖而言，云、水、雪的 NDVI 为负值，岩石、裸土的 NDVI 近于 0，而有植被

覆盖的 NDVI 为正值。为便于处理，对数据进行波段运算（ENVI-BasicTools-BandMath），表

达式为（b1 lt 0）*0+（b1 ge 0）*（b1*0.0001），其中 b1 为拼接转投影之后的影像。即将小

于 0 的值赋予 0，大于等于 0 的值乘以 0.0001，这样就把 NDVI 的值域转化为[0，1]。 

第四步，NDVI 年最大值合成。最大值合成即从几幅影像中选取最大像元值重新生成一

幅新图像。方法为：在 ENVI 软件中打开所有影像(假设有 n 个时期的影像)，然后选择对应

的影像进行波段运算（b1>b2>b3>b4>…. bn），结果即为 NDVI 最大合成影像。 

(2) VegCover_0 (植被覆盖度) 

获取 NDVI 最大合成影像后，运用像元二分模型反演植被盖度。公式为： 

 

公式中，VC为植被覆盖度，NDVIsoil代表裸土或无植被覆盖区域的NDVI值，NDVIveg代

表完全被植被覆盖区域的NDVI值。 

(3) RR1_0 (LCM模型中的下渗系数r) 

获取方法详见 “4.2 入渗系数空间离散化操作”。 

(4) Slope_0(坡度图) 

获取研究区DEM数据，运用ArcMap软件，通过ArcMap-ArcToolbox-Spatial Analyst 

Tools- Surface-Slope 提取坡度图。 

(5) Flowdir_0 (流向图) 

获取研究区DEM数据，运用ArcMap软件，通过ArcMap-ArcToolbox-Spatial Analyst 

Tools- Hydrology-Flow Direction 提取流向图。 

(6) Landuse_0 (土地利用图) 

获取研究区不同季相遥感影像，通过人机交互式方法解译提取。具体分类系统为： 
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代码 地类 代码 地类 代码 地类 代码 地类 

111 山区水田 21 有林地 42 湖泊 61 沙地 

112 丘陵区水田 22 灌木林地 43 水库、坑塘 62 戈壁 

113 平原区水田 23 疏林地 44 冰川和永久积雪地 63 盐碱地 

114 >25坡度区的水田 24 其他林地 45 海涂 64 沼泽地 

121 山区旱地 31 高覆盖度草地 46 滩地 65 裸土地 

122 丘陵区旱地 32 中覆盖度草地 51 城镇用地 66 裸岩石砾地 

123 平原区旱地 33 低覆盖度草地 52 农村居民点用地 67 其它 

124 >25坡度区的旱地 41 河渠 53 工交建设用地   

(8) Clay_U_0(土壤粘粒含量)、OC_U_0(土壤有机碳含量)、Sand_U_0(土壤砂粒含量)、

Silt_U_0(土壤粉粒含量)、Rock_U_0(土壤砾石含量) 

第一步，从世界土壤数据库 HWSD 提供矢量化 1：100 万中国土壤数据中，裁剪出研究

区土壤图，取名为 soil.shp。 

第二步，按土壤图属性表中的 SOIL 字段和 HWSD.mdb 属性表中 MU_SOURCE1 字段

相同，分别查找、记录每种土壤类型的砂粒含量 T_SAND、粘粒含量 T_CLAY、粉粒含量

T_SILT、有机碳含量 T_OC 和碎石含量 T_GRAVEL 等特征参数。 

第三步，运用 ArcMap 中，打开土壤图 soil.shp 的属性表并在属性表中添加 5 个新字段，

即 T_SAND、T_CLAY、T_SILT、T_OC 和 T_GRAVEL，将第二步中记录下的砂粒含量

T_SAND、粘粒含量 T_CLAY、粉粒含量 T_SILT、有机碳含量 T_OC 和碎石含量 T_GRAVEL

等特征参数，按土壤类型对应新添加的字段添加进入 soil.shp 的属性表中，生产新的土壤图，

取名为河龙 soil.shp。 

第四步，获取土壤质地栅格数据。具体为，在 ArcMap 中，打开土壤图 newsoil.shp，通

过 ArcMap-ArcToolbox-Conversion Tools-To Raster-Feature to Raster，下拉 Field 字段，选择

T_CLAY，生成以下页面，点击 ok 键，即可生成粘粒含量栅格数据，取名为 Clay_U.tif。之

后，以此类推。下拉 Field 字段，选择 T_SAND，生成砂粒含量栅格数据，取名为 Sand_U.tif。

下拉 Field 字段，选择 T_SILT，生成粉粒含量栅格数据，取名为 Silt_U.tif。下拉 Field 字段，

选择 T_OC，生成有机碳含量栅格数据，取名为 OC_U.tif。下拉 Field 字段，选择 T_GRAVEL，

生成有砾石含量栅格数据，取名为 Rock_U.tif。 
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第五步，将 tif 格式土壤质地栅格数据转换为 ENVI 标准格式。如：在 ENVI 中打开

Clay_U.tif，通过 ENVI-File-Save File As-ENVI Standard，生成 ENVI 标准格式 Clay_U_0。以

此类推，将 Sand_U.tif、Silt_U.tif、OC_U.tif、Rock_U.tif 分别转换为 ENVI 标准格式，并取

名为 Sand_U_0、Silt_U_0、OC_U_0、Rock_U_0。 

4.3.3 文本数据 Resolution_txt 

获取影像数据的像元大小，生成两行两列的文本文档，取名为 Resolution_txt.txt。如：

像元大小为 1000m×1000m，则生成的文本文档格式如下： 
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5. Nitrogen 模型预处理操作 

Nitrogen 模型数据准备过程包括：数据预处理模块、遥感参数估算模块、水文模型、植

被 NPP 估算、土壤侵蚀量估算、施肥模块等七个部分。Nitrogen 模型结构如图 5-1 所示。具

体包括：降雨空间插值、MODIS/GLDAS 数据处理、植被盖度计算、根系深度计算、潜在蒸

散法估算、DTVGM 计算、土壤温度计算、MUSLE 计算、NPP 计算等。其中植被盖度计算、

根系深度计算和潜在蒸散法估算同 DTVGM 模型预处理操作。 

 

图 5-1 分布式 Nitrogen 模型总体结构示意图 
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图 5-2 Nitrogen 模型预处理程序示意图 

5.1N、P 参数赋初值 

模型名称：EcoHAT_Nitrogen_Pre_N_P_Initialize 

5.1.1 程序输入数据说明 

输入数据（下图）包括上层土壤容重（Bulk_U_0）、下层土壤容重（Bulk_L_0）、土地利

用数据（Landuse_0）、植被掉落物数据（Lit_2013365）、土壤类型数据（Soil_type_0）和两个

参数文本数据（parameter1 和 parameter2）。 

 

5.1.2 程序输出数据说明 

氮素初始化数据包括：NH4_U_2014001（初始上层氨氮量）、NH4_L_2014001（初始下

层氨氮量）、NO3_U_2014001（初始上层硝态氮量）、NO3_L_2014001（初始下层硝态氮量）、

ONA_U_2014001（初始上层活跃态有机氮量）、ONA_L_2014001（初始下层活跃态有机氮量）、

ONF_U_2014001（初始上层新鲜有机氮量）、ONS_U_2014001（初始上层稳定态有机氮量）、

ONS_L_2014001（初始下层稳定态有机氮量）、OC_U_0（初始上层有机碳）和 OC_L_0（初

始下层有机碳）。 

磷素初始化数据包括：MPA_U_2014001（初始上层活跃态矿物质磷）、MPA_L_2014001

（初始下层活跃态矿物质磷）、 MPS_U_2014001（初始上层稳定态矿物质磷）、

MPS_L_2014001（初始下层稳定态矿物质磷）、OP_U_2014001（初始上层有机磷）、

OP_L_2014001（初始下层有机磷）、OPF_U_2014001（初始上层新鲜有机磷）、PSO_U_2014001
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（初始上层可溶性磷）和 PSO_L_2014001（初始下层可溶性磷）。 
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5.1.3 程序运行注意事项 

注意文件的命名，文本文件参数的修改和程序中输入输出的修改。 

5.2 施肥计算 

模型名称：EcoHAT_Nitrogen_Pre_Fert 

5.2.1 程序输入数据说明 

输入数据（如下图）包括：土地利用数据（Landuse）和施肥参数文本数据（Fert_para_txt_0）. 

 

5.2.2 程序输出数据说明 

输出数据为铵态氮日数据，硝态氮日数据和可溶性磷日数据。模型运行前请建立各自的

文件夹以放置数据。 

 

5.2.3 程序使用注意事项 

程序的使用注意主要有输入数据的命名，文本参数的修改和程序中相关位置的修改（已

在程序中标注）。 

5.3 植被盖度计算 

5.3.1 数据准备 

模型名称：EcoHAT_DTVGM_Pre_Vegcover 

表 5-1 EcoHAT_DTVGM_Pre_Vegcover 输入数据 

序号 输入参数 数据格式 内容 单位 

1 RS_para_txt_0 文本格式 时区中心经度 ° 

2 Longitude_0 影像格式 经度图 ° 

3 Latitude_0 影像格式 纬度图 ° 

4 Q_0 影像格式 聚集指数 - 
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5 LAI+日期 影像格式 叶面积指数 - 

6 ViewTime+日期 影像格式 MODIS 影像过境时间 h 

 

表 5-2 EcoHAT_DTVGM_Pre_Vegcover 输出数据 

序号 输出参数 数据格式 内容 单位 

1 Vegcover+日期 影像格式 植被盖度 - 

 

 

图 5-3EcoHAT_ DTVGM_Pre_Vegcover 程序界面 

5.3.2 植被盖度计算操作 

计算 Vegcover 之前需要计算经纬度图、聚集指数 Q_0、LAI 和过境时间。其中经纬度

图 制 作 参 看 DTVGM 模 型 中 经 度 图 和 纬 度 图 的 制 作 步 骤 ， 过 境 时 间 由

EcoHAT_DTVGM_Pre_Viewtime 计算得到。LAI 数据可采用 MODIS 数据的 MOD13 产品，

Q_0 则根据研究区土地利用类型按照表 5-3 分别赋值。 

表 5-3  不同 IGBP 类型的典型聚集指数 
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类型代码 类型名 
 

类型代码 类型名 
 

1 常绿针叶林 0.6 10 草地 0.9 

2 常绿阔叶林 0.8 11 永久湿地 0.9 

3 落叶针叶林 0.6 12 农田 0.9 

4 落叶阔叶林 0.8 13 城市和建设用地 0.9 

5 混合林 0.7 14 农作物和自然植被交错区 0.9 

6 郁闭灌丛 0.8 15 雪/冰 0.9 

7 开放灌丛 0.8 16 裸地或稀疏植被 0.9 

8 有林草原 0.8 17 水体 0.9 

9 稀树草原 0.8    

5.4 降雨空间插值 

5.4.1 数据准备 

模型名称：EcoHAT_Nitrogen_Pre_PrecipInterpolation 

表 5-4 EcoHAT_Nitrogen_Pre_PrecipInterpolation 输入数据 

序号 输入参数 数据格式 内容 单位 

1 站点.txt 文本格式 场次降雨摘录表文本 - 

2 201401.txt 文本格式 日降雨数据文本 mm 

表 5-5 EcoHAT_Nitrogen_Pre_PrecipInterpolation 输出数据 

序号 输出参数 数据格式 内容 单位 

1 01.txt 文本格式 日降雨数据 mm 

 

 
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图 5-4 EcoHAT_Nitrogen_Pre_PrecipInterpolation 程序界面 

5.4.2 降雨时间插值操作 

第一步，在中国气象数据网上 http://data.cma.cn/下载日降水数据，再根据研究区内及周

边气象站点进行气象数据的筛选，并查找各气象站点的空间位置信息。日降水数据指定命名

格式为年+月.txt，如 201401.txt，主要字段包括：区站号、年、月、日和 PRE 五个字段，如

图 5-5 所示。气象站点的空间位置信息无指定命名格式，主要字段包括：区站号、经度、纬

度三个字段，如 5-6 所示。 

http://data.cma.cn/
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图 5-5 三江平原气象站点降雨数据 

 

图 5-6 三江平原气象站点数据 

第 二 步 ， 结 合 气 象 站 空 间 坐 标 信 息 及 对 应 日 降 雨 数 据 ， 利 用

EcoHAT_Nitrogen_Pre_PrecipInterpolation.pro 程序对原始数据进行预处理，整理获得各月份

的降雨插值站点属性表，如图 5-7 所示。 
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图 5-7 三江平原降雨插值站点属性表 

第三步，启动 ArcGIS 10.3 程序，选择 File—Add Data—Add XY Data 模块，将各月降雨

插值站点属性表依次添加到 ArcGIS 10.3 中，并输出生成降雨空间插值.shp 文件。该文件是

ArcGIS 降雨空间插值批处理的数据基础，如图 5-8 所示。注意添加的 XY Data 应该与计算

模型的投影及椭球体保持一致。 

 

图 5-8 ArcGIS 空间插值批处理插值站点.shp 文件 

第四步，利用 Excel 生成批处理插值代码，选择降雨空间插值.shp 文件所在路径，同时

选择插值结果输出路径，注意填写.tif 后缀，空间分辨率等信息，如图 5-9 所示，按上述步

骤进行整理，即可获得 ArcGIS 空间插值批处理代码文本。 



119 

 

 

图 5-9 ArcGIS 空间插值批处理代码 

第五步，将生成的批处理代码拷贝至 ArcGIS: ArcToolBox—Spatial Analyst Tools—

Interpolation—IDW（batch）对话框中，如图 5-10 所示。为了保证输出结果在范围与栅格空

间位置上与模型其他输入数据保持一致，需要对 Environmental setting 属性进行设置，按照

Environmental setting—Processing Extent 的路径找到：Extent 和 Snap Raster 属性，分别按照

模型已有输入数据进行设置，即可批处理运行 IDW 插值程序，实现降雨数据空间插值计算，

如图 5-11 所示。取消 ArcGIS 计算结果自动加载功能可以节省插值处理耗时、提高系统运行

效率，具体方法如下：在 Geoprocessing—Geoprocessing Options 下取消“Add results of 

geoprocessing operations to the display”即可。 
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图 5-10 ArcGIS 空间插值批处理界面 

 

图 5-11 ArcGISEnvironmental Setting 设置界面 

最后，利用批处理裁剪程序对降雨空间插值结果按照研究区边界boundary_0进行裁剪。 
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5.5 土壤温度计算 

5.5.1 数据准备 

模型名称：EcoHAT_Nitrogen_Pre_SoilTemperature 

表 5-6 EcoHAT_Nitrogen_Pre_SoilTemperature 输入数据 

序号 输入参数 数据格式 内容 单位 

1 Tsoil_para.txt 文本格式 土壤温度计算参数 - 

2 Tsoil_U+日期 影像格式 前一天上层土壤温度 ° 

3 Tsoil_L+日期 影像格式 前一天下层土壤温度 ° 

4 SW_U+日期 影像格式 上层土壤含水量 % 

5 SW_L+日期 影像格式 下层土壤含水量 % 

6 LST+日期 影像格式 地表温度 ° 

 

表 5-7 EcoHAT_Nitrogen_Pre_SoilTemperature 输出数据 

序号 输出参数 数据格式 内容 单位 

1 Tsoil_U+日期 影像格式 当天上层土壤温度 ° 

2 Tsoil_L+日期 影像格式 当天下层土壤温度 ° 
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图 5-12 EcoHAT_Nitrogen_Pre_SoilTemperature 程序界面 

5.5.2 土壤温度计算操作 

计算土壤温度之前需要计算前一天上下层土壤温度、当天上下层土壤含水量和地表温度

LST。 

首先，将 DTVGM 模型输出的研究区日尺度的上下层土壤水数据 End_AWui_+日期和

End_AWdi_+日期，分别替换名字为 SW_U+日期和 SW_L+日期。然后需要对第一天的

Tsoil_U 和 Tsoil_L 数据赋初值，可直接采用 LST 数据。该程序采用迭代算法，要求将 Tsoil_U

和 Tsoil_L 的输入输出数据放在同一个文件夹下。LST 数据可采用 MODIS 数据的 MOD11

产品。最后，将准备好的数据带入 EcoHAT_Nitrogen_Pre_SoilTemperature 程序进行运算。 

5.6 太阳辐射计算 

5.6.1 数据准备 

模型名称：Rs_function 

表 5-8 Rs_function 输入数据 

序号 输入参数 数据格式 内容 单位 
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1 Rs_para_txt_0.txt 文本格式 太阳辐射参数 - 

2 DEM_0 影像格式 高程数据 m 

3 Latitude_0 影像格式 纬度 ° 

4 Longitude_0 影像格式 经度 ° 

5 ViewTime+日期 影像格式 卫星过境时间 h 

6 T_rise+日期 影像格式 日出时间 h 

7 T_set +日期 影像格式 日落时间 h 

 

表 5-9 Rs_function 输出数据 

序号 输出参数 数据格式 内容 单位 

1 Q_day+日期 影像格式 日太阳辐射 MJ/m2 

 

图 5-13 Rs_function 程序界面 

5.6.2 太阳辐射计算操作 

计算 Q_day 之前需要计算 DEM、经纬度图、过境时间和日出日落时间。其中 DEM_0

可采用 ASTER 的 30m 分辨率数据或者 SRTM 的 90m 分辨率数据，经纬度图制作参看

DTVGM 模型中经度图和纬度图的制作步骤，过境时间和日出日落时间分别由

EcoHAT_DTVGM_Pre_Viewtime 和 EcoHAT_DTVGM_Pre_suntime 计算得到。最后，用

ENVI4.4 打开程序，点击文件菜单，选择新建工程路径，在常用计算菜单中，选择太阳辐射

计算。 
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5.7NPP 计算 

5.7.1 数据准备 

模型名称：NPP_casa_function 

表 5-10 NPP_casa_function 输入数据 

序号 输入参数 数据格式 内容 单位 

1 NPP_txt_0.txt 文本格式 光合有效辐射与太阳总辐射

的比例因子 

- 

2 Landuse_0 影像格式 土地利用数据 - 

3 Q_day+日期 影像格式 太阳辐射 MJ/m2 

4 Tair+日期 影像格式 平均大气温度 ℃ 

5 Fpar+日期 影像格式 植被层对入射光合有效辐射

的吸收比例 

% 

6 ETp+日期 影像格式 潜在蒸散发 mm 

7 ETa +日期 影像格式 实际蒸散发 mm 

 

表 5-11 NPP_casa_function 输出数据 

序号 输出参数 数据格式 内容 单位 

1 NPP+日期 影像格式 日植被初级生产力 g/m2 
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图 5-14 NPP_casa_function 程序界面 

5.7.2NPP 计算操作 

计算 NPP 之前需要计算 Viewtime、Q_day、ETp、ETa 和 Fpar。其中 Viewtime 和 ETp

的计算见 DTVGM 模型的预处理程序，ETa 为 DTVGM 模型的计算结果，Q_day 计算见

Rs_Function，Fpar 数据可采用 MODIS 数据的 MOD15 产品。最后，用 ENVI4.4 打开程序，

点击文件菜单，选择新建工程路径，在植被生长模型菜单中，选择植被 NPP 计算（CASA）

选项。 

5.8 MUSLE 计算 

5.8.1 数据准备 

模型名称：EcoHAT_Nitrogen_Pre_MUSLE 

表 5-12 EcoHAT_Nitrogen_Pre_MUSLE 输入数据 

序号 输入参数 数据格式 内容 单位 

1 C_0 影像格式 覆盖-管理因子 - 

2 P_0 影像格式 水土保持措施因子 - 

3 LS_0 影像格式 地形因子 - 

4 Landuse_0 影像格式 土地利用类型 - 

5 Sand_U_0 影像格式 沙粒含量 % 
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6 Silt_U_0 影像格式 粉粒含量 % 

7 Clay_U_0 影像格式 粘粒含量 % 

8 OC_U_0 影像格式 有机碳含量 % 

9 Rock_U_0 影像格式 砾石含量 % 

10 Rs+日期 影像格式 地表径流量 mm 

 

表 5-13 EcoHAT_Nitrogen_Pre_MUSLE 输出数据 

序号 输出参数 数据格式 内容 单位 

1 Sed+日期 影像格式 土壤侵蚀量 t 

 

 

图 5-15 EcoHAT_Nitrogen_Pre_MUSLE 程序界面 

5.8.2MUSLE 计算操作 

第一步，覆盖与管理因子(C)和水土保持措施因子(P)赋值。可参考文献值对研究区各土

地利用类型分别进行 C 因子和 P 因子赋值，如下图所示。 
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其中 C 因子也可以运用蔡崇法(2000)提出的用植被盖度估算覆盖与管理因子(C)的方法

计算。公式为： 
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式中，C 为覆盖与管理因子，取值 0～1；Cv.是植被盖度，%。C 值越小，用于减沙的覆盖管

理措施越有效。 

第二步，地形因子(LS)赋值。参照 EcoHAT_LS_Factor_Procedure 进行 LS 因子赋值。 

第三步，土壤可蚀性因子(K)和粗碎屑因子(CFRG) 赋值。从世界土壤数据库 HWSD 提

供的矢量化 1：100 万中国土壤数据中，裁剪出研究区土壤类型图并导出属性表，例如：另

存为土壤参数获取.xlsx。按土壤参数获取.xlsx 中的 SOIL 字段和 HWSD.mdb 属性表中

MU_SOURCE1 字段相对应，分别查找、记录各土壤类型的砂粒含量 T_SAND 、粘粒含量

T_CLAY 、粉粒含量 T_SILT、有机碳含量 T_OC 和碎石含量 T_GRAVEL 等特征参数。在

ArcGIS 下将土壤类型图中各机械组成字段分别输出栅格数据，并转换为 ENVI 标准格式，

指定命名为 Sand_U_0、Silt_U_0、Clay_U_0、OC_U_0、Rock_U_0。 

最后，将以上数据结合 DTVGM 模型输出的研究区地表径流数据 (Rs)，利用

EcoHAT_Nitrogen_Pre_MUSLE.pro 程序进行土壤侵蚀量计算。 
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6. Phosphorus 模型预处理操作 

具体操作同 Nitrogen 模型预处理操作。 

7. EcoHAT 预处理过程列表 

参见 EcoHAT 模型预处理操作。 


